.
Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | links | news | email login | chat Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Page 1 of 2 1 2 >
Topic Options
#1076819 - 11/30/06 01:15 AM 2003 CVPI Power Steering pump whine
Unixadm Offline
Member

Registered: 10/14/02
Posts: 179
Loc: Sacramento, CA
My 2003 CVPI seems to have a power steering pump whine. I went ahead and flushed the fluid tonight to see if the noise would improve any and it didn't. At idle you cannot really hear the whine unless you are under the hood listening closely. However if you turn the steering wheel a bit and give it some throttle you can hear the whine.

So if I want the whine to go away, I need to change the PS Pump. Has anyone done this on a 2003+? If so, was it a difficult job? I have changed pumps before and have the pulley puller/installer.

Lastly is the pump different from a civilian CV and the CVPI? My car is a very early 2003 (04/02). I do not want an aftermarket pump. I'll buy a Motorcraft pump from Ford. I just want the whining to go away.
_________________________
UNIXADM - 2007 CVPI Street and Appearance Package, Smokestone Metallic / Dark Charcoal, 100k (337 idle hours)

Top
Links
#1076820 - 11/30/06 07:42 AM Re: 2003 CVPI Power Steering pump whine
gord_bolton Offline
Over the Hill

Registered: 05/06/02
Posts: 4691
Loc: Saskatoon, Saskatchewan
Ford power steering pumps like to whine. It is a fact of life. If the fluid level is OK and it works fine I would not bother trying to make the whine go away.

Top
#1076821 - 11/30/06 09:09 AM Re: 2003 CVPI Power Steering pump whine
2004_p71 Offline

no replacement for displacement
Grand Poobah

Registered: 09/04/03
Posts: 12224
Loc: Quebec Canada
I had the same problem on my 2003 p71..i did replace the pump by an aftermarket... was not an good idea at all it,s even worst .So i bought some additive made by lucass i replaced maybe half of the bottle in it and the sound is lot more better but as gord said it is a fact of life.
_________________________


04 is getting back on track with the new 5.4 laugh

Top
#1076822 - 11/30/06 02:02 PM Re: 2003 CVPI Power Steering pump whine
Unixadm Offline
Member

Registered: 10/14/02
Posts: 179
Loc: Sacramento, CA
The power steering works okay, but the whining noise is annoying. My 2003 Maruader did not whine and my 1999 CVPI did not whine. I'll do a full flush this weekend and see if it helps. If not, I'm going to order a new Motorcraft pump and install it.

Ford and their power steering pumps - I've heard plenty of Aerostars!
_________________________
UNIXADM - 2007 CVPI Street and Appearance Package, Smokestone Metallic / Dark Charcoal, 100k (337 idle hours)

Top
#1076823 - 11/30/06 02:14 PM Re: 2003 CVPI Power Steering pump whine
MIAMI-DADE Offline
Over the Hill

Registered: 06/19/05
Posts: 4185
Loc: Miami-Dade County
My 05 and and my dads 05 both whine a little.My 99 didn't make a sound.BTW on the both 05's the front ends creak like crazy.

On the 99 there was no whine and the front end creaked but much less then the 05's.
_________________________

05 Crown Vic/LX/160K miles
07 Grand Marquis/LS 50K miles
05 Crown Vic [sold]
99 GMQ with HPP [sold] 200K miles
88 Town Car [sold] 320K miles
88 Crown Vic [sold] 230K miles
85 Crown Vic [sold] 215K miles

Top
#1076824 - 11/30/06 05:59 PM Re: 2003 CVPI Power Steering pump whine
Unixadm Offline
Member

Registered: 10/14/02
Posts: 179
Loc: Sacramento, CA
My front end does not make any noises on my 2003. The suspension is squeak and rattle free at 100k. The only squeaking I had was from the hood latch assembly.
_________________________
UNIXADM - 2007 CVPI Street and Appearance Package, Smokestone Metallic / Dark Charcoal, 100k (337 idle hours)

Top
#1076825 - 11/30/06 06:03 PM Re: 2003 CVPI Power Steering pump whine
WhiskeyTangoFox Offline
Over the Hill

Registered: 04/13/05
Posts: 1232
Loc: Garden Grove, Kalifornia
The 1999 (up to and including MY02) CVs did not have rack and pinion steering, thus they were less likely to whine.

We have what's called a 'recirculated bearing' steering system, if I remember correctly.

As for loud steering pumps, that's been normal for any rack-and-pinion based steering system I've had from Ford (95 Ranger, 88 Aerostar, 97 Aerostar).
_________________________
2000 CVPI, 180k+ and still going... (RIP 3/2011)

Top
#1076826 - 11/30/06 06:09 PM Re: 2003 CVPI Power Steering pump whine
Mileaway Offline
Posting Addict

Registered: 10/06/05
Posts: 16817
Loc: Sacto. Calif.
Mine started doin that when it got cold here in Sac, a few days ago but other than new fluid,I would just get used to it.Is it really loud?All the Aerostar vans do it like they said so it's a Ford thing. You don't smell any burning correct? Real low fluid will burn the pump and that squeals loud and you can smell it-that's a problem but your talking about that slight noise when the wheel is starting to turn correct?
_________________________
2000 P71 Interceptor orig. equip.near mint parchment int.& carpet 155,000 mi. 3.55 rear


Little Anthony: That's all the television there is.











Top
#1076827 - 11/30/06 06:15 PM Re: 2003 CVPI Power Steering pump whine
Unixadm Offline
Member

Registered: 10/14/02
Posts: 179
Loc: Sacramento, CA
It's louder than normal and is easily audible inside of the car with the windows up. This was a cold climate car and the fluid I took out was pretty dark and nasty. My point of comparison was my 2003 Marauder which didn't have any whining sound. I also have a 2006 Mustang GT that does not whine either. The fluid level was fine when I got the car. I don't know the history except for the past week or two that I've owned the car.
_________________________
UNIXADM - 2007 CVPI Street and Appearance Package, Smokestone Metallic / Dark Charcoal, 100k (337 idle hours)

Top
#1076828 - 11/30/06 06:37 PM Re: 2003 CVPI Power Steering pump whine
06vic Offline
Over the Hill

Registered: 06/30/06
Posts: 2800
Loc: Phoenix, AZ
Loud power steering pumps seem to be a Ford trademark, a rather irritating trademark. It's so common it's hard to understand why Ford has never addressed it. I started a thread about this very thing several months ago.My girlfriends '89 Bronco does it and my brothers 03 Marauder with only 20 something thousand miles has gotten loud recently too. I guess I can be looking forward to the same crap in another year or 2. I'll enjoy my temporary power steering pump silence while it lasts.
_________________________

Top
#1076829 - 11/30/06 08:10 PM Re: 2003 CVPI Power Steering pump whine
MIAMI-DADE Offline
Over the Hill

Registered: 06/19/05
Posts: 4185
Loc: Miami-Dade County
Quote:

My front end does not make any noises on my 2003. The suspension is squeak and rattle free at 100k. The only squeaking I had was from the hood latch assembly.




Will check out the hood latch assembly.
_________________________

05 Crown Vic/LX/160K miles
07 Grand Marquis/LS 50K miles
05 Crown Vic [sold]
99 GMQ with HPP [sold] 200K miles
88 Town Car [sold] 320K miles
88 Crown Vic [sold] 230K miles
85 Crown Vic [sold] 215K miles

Top
#1076830 - 11/30/06 08:23 PM Re: 2003 CVPI Power Steering pump whine
Unixadm Offline
Member

Registered: 10/14/02
Posts: 179
Loc: Sacramento, CA
Quote:

Will check out the hood latch assembly.




Good luck with that. My hood latch squeaked LOUDLY. The whole car sounded like a POS just driving down the road. I thought I had many hours of lubing the suspension and such to fix that nasty squeaking until my buddy and I started listening for it. The first clue it was not the suspension was if I shut the drivers door with any amount of force, you would hear a brief squeaking noise. After a few tries we popped the hood and the noise went away. I would have swore the noise was coming from the rear of the front drivers side fender, but it ended up being the latch. Some 3-in-1 oil and all the squeaking was gone. I then didn't have to duck down and hide in the car while driving it. lol
_________________________
UNIXADM - 2007 CVPI Street and Appearance Package, Smokestone Metallic / Dark Charcoal, 100k (337 idle hours)

Top
#1076831 - 11/30/06 08:25 PM Re: 2003 CVPI Power Steering pump whine
Darnon Offline
Over the Hill

Registered: 02/12/06
Posts: 1730
Loc: Attica, NY
Extend the little bolts with a rubber foot on top so it presses the hood firmly up against the latch when closed. Don't go too crazy at first or you can damage the plastic piece they thread into.
_________________________
How a politician stands on the Second Amendment tells you how he or she views you as an individual; as a trustworthy & productive citizen or as part of an unruly crowd that needs to be lorded over, controlled, supervised, and taken care of. -Texas State Representative Dr. Suzanna Hupp

Top
#1076832 - 11/30/06 08:28 PM Re: 2003 CVPI Power Steering pump whine
MIAMI-DADE Offline
Over the Hill

Registered: 06/19/05
Posts: 4185
Loc: Miami-Dade County
Quote:

Quote:

Will check out the hood latch assembly.




Good luck with that. My hood latch squeaked LOUDLY. The whole car sounded like a POS just driving down the road. I thought I had many hours of lubing the suspension and such to fix that nasty squeaking until my buddy and I started listening for it. The first clue it was not the suspension was if I shut the drivers door with any amount of force, you would hear a brief squeaking noise. After a few tries we popped the hood and the noise went away. I would have swore the noise was coming from the rear of the front drivers side fender, but it ended up being the latch. Some 3-in-1 oil and all the squeaking was gone. I then didn't have to duck down and hide in the car while driving it. lol




Its doing the exact same as yours.
Thanks for the info for sure!
_________________________

05 Crown Vic/LX/160K miles
07 Grand Marquis/LS 50K miles
05 Crown Vic [sold]
99 GMQ with HPP [sold] 200K miles
88 Town Car [sold] 320K miles
88 Crown Vic [sold] 230K miles
85 Crown Vic [sold] 215K miles

Top
#1076833 - 11/30/06 08:30 PM Re: 2003 CVPI Power Steering pump whine
MIAMI-DADE Offline
Over the Hill

Registered: 06/19/05
Posts: 4185
Loc: Miami-Dade County
Quote:

Extend the little bolts with a rubber foot on top so it presses the hood firmly up against the latch when closed. Don't go too crazy at first or you can damage the plastic piece they thread into.




Thanks i hear ya.
_________________________

05 Crown Vic/LX/160K miles
07 Grand Marquis/LS 50K miles
05 Crown Vic [sold]
99 GMQ with HPP [sold] 200K miles
88 Town Car [sold] 320K miles
88 Crown Vic [sold] 230K miles
85 Crown Vic [sold] 215K miles

Top
Page 1 of 2 1 2 >



Moderator:  dRock96Marquis, Liquid 
Who's in Chat??
Google!
Who's Online
9 registered (DaveTheJoker, bluviclx98, alexcrownvic, 4 invisible), 65 Guests and 63 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
BigMerc96 152
Ezbok58a 148
road_pizza 136
ponyguy 120
a_d_a_m 116
BlackVic_P71 115
aknox077 91
Chaplian 89
73vwTodd 84
KayTar 83
Featured Member
Registered: 07/24/11
Posts: 8





Copyright 2000-2013 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!