.
Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | links | news | email login | chat Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Page 1 of 2 1 2 >
Topic Options
#2140315 - 09/15/10 10:22 AM I think my Alternator is going bad...
KiDD_QuE Offline
Rookie

Registered: 07/09/10
Posts: 75
Loc: Texas
I was driving from work yesterday and while i was driving on the highway my voltage started to drop. I could see the volt meter go from midway(normal) all the way down to below 25%. I think its my alternator but i am not sure, also when i got home from work, my engine was making a weird scratching noise. Nothing loud or major, but it wasn't normal. I would also like to know would it be better to rebuild my alternator (assuming its the police alternator) or have a new civy installed?
_________________________


05 P71 Crown Vic

19 years old with a vic, who says vics are for old people?

Top
Links
#2140321 - 09/15/10 10:36 AM Re: I think my Alternator is going bad... [Re: KiDD_QuE]
SCHALLZ Offline
Poobah

Registered: 07/02/09
Posts: 5403
Loc: La Crosse WI, USA
first i would take the alt off take it into an auto store and have it bench tested

do you have alot of extra eletronics running (lights, subs, amps?)

and when you started the car the next time was it still making the noise?
_________________________

02 Grand Marquis 150,xxx miles Mod List:
Click to reveal..
MZT, Hi Tech stage 2 cams, Edge Racing 3500 stall converter, SW headers w/ offroad lead pipes, SW cat back exhaust w/ Chambered mufflers, P&P'd Accufab plenum, TB & Plenum spacer, Half shafted/P&P'd BBK 75mm tb, Typhoon intake, BBK valve covers, 4.10 LSD, J-mod, Steeda underdrive pulleys, 6000K 55watt dual beam HID's w/ BH1976 relay upgrade kit.
Interior Mods:
Click to reveal..
Kenwood DNX6160 double din, Massive Audio rear components and Hertz Energy front components, 3 15" Kicker CVR's, 2180 watts worth of Memphis amps, Raptor 2.5 farad capacitor, 200 amp Ohio Generator alt, and about 200' of soundmat.

The Womans fears have become a reality. Injured on 09/15/10 and is now reborn, coming soon Zex wet kit " There is nothing like a Marquis on juice its like giving an old man viagra "

Top
#2140338 - 09/15/10 11:00 AM Re: I think my Alternator is going bad... [Re: SCHALLZ]
KiDD_QuE Offline
Rookie

Registered: 07/09/10
Posts: 75
Loc: Texas
I might just do that, if its bad, do you know where i can get another police alternator? And no, the only electronics i have is a head unit, and hids if that counts. When I turned the car off and back on the noise went away.
_________________________


05 P71 Crown Vic

19 years old with a vic, who says vics are for old people?

Top
#2140347 - 09/15/10 11:09 AM Re: I think my Alternator is going bad... [Re: KiDD_QuE]
Tracy Offline
Over the Hill

Registered: 09/07/09
Posts: 3826
Loc: West Bend, WI, USA
 Originally Posted By: KiDD_QuE
I might just do that, if its bad, do you know where i can get another police alternator? And no, the only electronics i have is a head unit, and hids if that counts. When I turned the car off and back on the noise went away.


You could try the auto parts store you take it to, rock auto, or ebay.

Before you pull the alternator off, test the battery when the engine running with a multimeter, you should get somewhere around 14.5 volts if it's working properly.



Edited by Tracy (09/15/10 11:10 AM)
_________________________
1999 Deep Wedgewood Blue & Rust P71, 21x,xxx miles, full cloth interior, 3L55 RAR, BH1976 Headlight Relay Harness, and a few other mods. Former Chippewa Falls, WI PD car. I'm the 3rd owner of car.
Now with Mustang Wheels, Honeycomb Grille, and Ford AM/FM CD player with RDS.



Download your Owner's Manual FREE from the Ford Owner's Site

Top
#2140370 - 09/15/10 11:40 AM Re: I think my Alternator is going bad... [Re: Tracy]
SPM Offline
Over the Hill

Registered: 09/10/09
Posts: 1468
Loc: Wisconsin
When the alternator in my car gave out, the first symptom was a lower-than-normal voltage gauge quickly followed by a continuously lit battery warning light. Using a multimeter, I was getting ~12 volts at the battery with the engine off, and it was down to ~11.5 volts with the engine on indicating a no-charge condition (Engine on voltage should be 14 to 14.5 volts).

Took the alternator off and had it bench-tested at Autozone, and it flunked almost immediately. My first replacement unit from Autozone was actually bad too (it also flunked the bench test), but the second replacement has performed flawlessly for three months.

Test your voltage with engine-off, and then engine-on. If it's not within spec, have the alternator tested. If it fails, that's your culprit.
_________________________

2005 Grand Marquis LS, 75K miles
2000 CVPI, 229K miles (Sold)

Top
#2140401 - 09/15/10 12:14 PM Re: I think my Alternator is going bad... [Re: SPM]
Xerses Offline
Climber

Registered: 04/06/10
Posts: 774
Loc: Ste-Therese, Quebec, Canada
Be sure to check this out...

http://www.crownvic.net/ubbthreads/ubbthreads.php?ubb=showflat&Number=2136757#Post2136757

Very good info from 2vmodular about possible cause to your issue, but not the noise. That could be clutch bearing in the alternator. Mine whines when it spins down from revving. The day it gives out I will change it.
_________________________
2006 P71 - SOLD!
Owner of a 2014 Subcompact, half the size & half the weight of my old P71, but 1/4th the gas! Will eventually rejoin the Crown Vic family.

Top
#2140434 - 09/15/10 12:51 PM Re: I think my Alternator is going bad... [Re: Xerses]
Bonekrosha Offline
Member

Registered: 04/08/10
Posts: 213
Loc: Tennessee
I got a bad Alt off the shelf from them too, took it back, the next one was bad off the shelf too, luckily they ordered two in the 2nd time around.
Also, lucky for me they have lifetime warranties.
The above link is really good.
Mine is starting to sporadically blink the Alt light now but the guage only fluctuates a little every now and then, sometimes when the light is on, the gauge shows no change.
I really think mine has to do with my battery harness needing replacement, that happens thins weekend.
Hope you get everything worked out!
_________________________
2001 P-71 Plain ole white ex-Po-Po car: 2-chamber Flowmasters with turndowns, 70mm Throttle Body, K&N Cold-Air Intake, 245/ZR50's on the front, 255/ZR50's with requisite dog dishes and trim rings. Alpine head unit to compete with the flowmasters.

Sold and still missed:
My old Beasty: 1994 P-71, my actual old Patrol Car that was auctioned off when I got my new Patrol Car in 2001. I found it on a car lot a year later for a song and sold it with 187K miles for twice what I paid for it. 2-Chamber Flowmasters with turndowns, cold air intake, 245/50's on 16" steelies with dog dishes.

Top
#2141288 - 09/16/10 02:08 PM Re: I think my Alternator is going bad... [Re: Bonekrosha]
Steve83 Offline
Poobah

Registered: 10/03/04
Posts: 7445
Loc: Memphis, TN 38002, USA, Earth,...
For the voltmeter to drop THAT rapidly, both the alt AND the battery have to have problems, and the car shouldn't start after you shut it off. Did you have to recharge the battery to get it cranked? In any case, recharge it before installing a new alt or you could damage the new one.

If you can't find a cop alt at a reasonable price, e-mail me about this one:

_________________________
Walk softly & carry a BIG SIX ! ! !

. . .

Top
#2141504 - 09/16/10 07:41 PM Re: I think my Alternator is going bad... [Re: Steve83]
KiDD_QuE Offline
Rookie

Registered: 07/09/10
Posts: 75
Loc: Texas
I bought a standard civy alternator. The guy at oreillys said that i wouldnt need the police alternator since i dont have all the equipment that police cars have. But before I install this alternator, do you think i should spend 140 more and get the police alt, or will the civy alt be fine
_________________________


05 P71 Crown Vic

19 years old with a vic, who says vics are for old people?

Top
#2141655 - 09/16/10 10:34 PM Re: I think my Alternator is going bad... [Re: KiDD_QuE]
Corsair Offline
Member

Registered: 07/17/05
Posts: 373
Loc: Port Wentworth,Ga
get the 130 amp one. I used to work at an Oreillys, and the guy who told you to put a smaller one on there was an idiot. with your a/c on high, which will have your cooling fan running on high speed, and your high beams on at night, your alt should be close to maxing out. never go with less than OEM for your car. you might want to install underbody lights and such later on. figure thats your car in sig post. tricking it out is easier with right stuff already in place.
_________________________
1996,2001, and daily drv., 1994 CVPI, 3.55 trac-lok,Go Rhino pushbumper,LED spotlight, J-Mod, Gemini overhead video/camera system, Havis console, ELS overhead shotgun rack, plus a few bells & whistles.

Top
#2141693 - 09/16/10 11:34 PM Re: I think my Alternator is going bad... [Re: Corsair]
SCHALLZ Offline
Poobah

Registered: 07/02/09
Posts: 5403
Loc: La Crosse WI, USA
im not sure about the 05's but mine only listed a 135a and a 200a

personally i wish i had the 200 but too much money i have the 135 with a smaller pulley have now for a few months and it works great

does your new alt look like the old one ?

is the plug the same

if so id think you ok but i do agree with corsair its always better to have the extra amps
_________________________

02 Grand Marquis 150,xxx miles Mod List:
Click to reveal..
MZT, Hi Tech stage 2 cams, Edge Racing 3500 stall converter, SW headers w/ offroad lead pipes, SW cat back exhaust w/ Chambered mufflers, P&P'd Accufab plenum, TB & Plenum spacer, Half shafted/P&P'd BBK 75mm tb, Typhoon intake, BBK valve covers, 4.10 LSD, J-mod, Steeda underdrive pulleys, 6000K 55watt dual beam HID's w/ BH1976 relay upgrade kit.
Interior Mods:
Click to reveal..
Kenwood DNX6160 double din, Massive Audio rear components and Hertz Energy front components, 3 15" Kicker CVR's, 2180 watts worth of Memphis amps, Raptor 2.5 farad capacitor, 200 amp Ohio Generator alt, and about 200' of soundmat.

The Womans fears have become a reality. Injured on 09/15/10 and is now reborn, coming soon Zex wet kit " There is nothing like a Marquis on juice its like giving an old man viagra "

Top
#2141699 - 09/16/10 11:39 PM Re: I think my Alternator is going bad... [Re: Corsair]
Skatertj Offline
Climber

Registered: 05/07/09
Posts: 624
Loc: Broken Arrow, OK
Sorry to hack, but i bought a new alt about a month and a half ago. The bad one would randomly give low charges and the battery light would flash for a sec. I bought a new one at autozone and now, with the car running, testing the battery with volt meter, i believe i get 13.2 or 13.8. Ill retest and then get the right amount. I know thats not normal but is it bad? and in the mornings at first start and any time its had time to cool off, the voltmeter in dash will be well above normal then drop to right below the top of battery icon after it warms up, where i can barely see the positive and negative battery symbols. Is that normal for where it should sit at? And once again, sorry for thread hack. Info given to me may help you out also!


Edited by Skatertj (09/16/10 11:41 PM)
_________________________


2001 CVPI 160,xxx 4.6l v8
Jmod, Thrush Turbos, Blinker mod, Led taillights with electronic lcm flasher, kenwood radio, sirius radio, PI Intake with aluminum crossover, Cragar Soft 8's, 4300k 35w ddmtuning HID's

Top
#2141744 - 09/17/10 12:59 AM Re: I think my Alternator is going bad... [Re: Skatertj]
KiDD_QuE Offline
Rookie

Registered: 07/09/10
Posts: 75
Loc: Texas
Im going to return this alt tomorrow, and try and find a police alt. Are the 99 and up alts the same, or do they vary? I might go look in the junk yard, or people that are parting out their cars or something
_________________________


05 P71 Crown Vic

19 years old with a vic, who says vics are for old people?

Top
#2141903 - 09/17/10 10:39 AM Re: I think my Alternator is going bad... [Re: KiDD_QuE]
Stick Offline
Climber

Registered: 11/29/07
Posts: 959
Loc: Oshawa Ontario Canada
Your 2005 came with a 200 amp altornator from the factory with the clutched pulley and the voltage regulator built in the PCM.
_________________________
2010 CVPI Black ]Jmod/rear bumper tuck /Head light harness upgrade

Top
#2141914 - 09/17/10 11:09 AM Re: I think my Alternator is going bad... [Re: KiDD_QuE]
Tracy Offline
Over the Hill

Registered: 09/07/09
Posts: 3826
Loc: West Bend, WI, USA
 Originally Posted By: KiDD_QuE
Im going to return this alt tomorrow, and try and find a police alt. Are the 99 and up alts the same, or do they vary? I might go look in the junk yard, or people that are parting out their cars or something


Try looking here:
http://p71interceptor.com/alternator/modelnumbers/

Might help in searching for a police alternator. Yes, 98-02 are the same as your 99.
_________________________
1999 Deep Wedgewood Blue & Rust P71, 21x,xxx miles, full cloth interior, 3L55 RAR, BH1976 Headlight Relay Harness, and a few other mods. Former Chippewa Falls, WI PD car. I'm the 3rd owner of car.
Now with Mustang Wheels, Honeycomb Grille, and Ford AM/FM CD player with RDS.



Download your Owner's Manual FREE from the Ford Owner's Site

Top
Page 1 of 2 1 2 >



Moderator:  dRock96Marquis, Liquid 
Who's in Chat??
Google!
Who's Online
17 registered (Bellwestern80, a_d_a_m, BlackVic_P71, 09mnsp, 06CrownVictoria, 3 invisible), 83 Guests and 59 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
Ezbok58a 197
BigMerc96 179
124neta 163
a_d_a_m 156
road_pizza 143
BigNSlow 136
Alex07 135
aknox077 119
ponyguy 111
2004_p71 95
Featured Member
Registered: 07/28/03
Posts: 422





Copyright 2000-2013 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!