Instrument Cluster Wiring

Posted by: Candi0830

Instrument Cluster Wiring - 08/02/19 08:24 PM

My husband was removing the dash's instrument cluster from his 2008 Police Interceptor in an attempt to diagnose the flickering and shutting off gauges/cluster lights. He was hoping to find a bad solder or loose wire, neither of which he found. He then began to try cleaning all the connections and he managed to pull a wire from the 32 pin connector and doesn't know where it came from. Here are a couple pictures of the remaining wires along with the black and yellow one next to it that is needing its proper placement. Anyone have a wiring diagram or a picture of their own cluster wires to help us out? [img]https://scontent-den4-1.xx.fbcdn.net/v/t...amp;oe=5DA0E49D[/img] [img]https://scontent-den4-1.xx.fbcdn.net/v/t...amp;oe=5DD45032[/img]
Posted by: bluejay_32

Re: Instrument Cluster Wiring - 08/02/19 08:30 PM

Black/Yellow is Pin 12. Green is Pin 1. Same side, fifth slot from the other end.
Posted by: Candi0830

Re: Instrument Cluster Wiring - 08/02/19 08:36 PM

Fantastic. Happen to know which light that wire controls?
Posted by: Bangster

Re: Instrument Cluster Wiring - 08/02/19 08:43 PM

Check out the article pined here for the odometer issue! oops reading comprehension issue, it isn't the odometer it is the backlighting

Spent too long adding points and text:
2008 CV INSTR by dabangsta, on Flickr

This one shows what the wire/pin is for:
2010 Crown Victoria Instrument Cluster 2 by dabangsta, on Flickr

And just to help make sure, this is another one with other wires to that connector:
2010 Crown Victoria Instrument Cluster 1 by dabangsta, on Flickr
Posted by: Candi0830

Re: Instrument Cluster Wiring - 08/02/19 08:49 PM

Thank you so much!
Posted by: Candi0830

Re: Instrument Cluster Wiring - 08/02/19 09:20 PM

Now all the lights work when it does flicker on. Think he is going to send it in for repair. Can't seem to pinpoint the loose connection. Thanks for your help. He bet me a night out with a fancy dinner if I could get him the answer! Lol
Posted by: bluejay_32

Re: Instrument Cluster Wiring - 08/02/19 11:04 PM

The dim/flickering odometer is a common problem. Bad solder joints on the circuitboard.
https://www.crownvic.net/ubbthreads/ubbthreads.php?ubb=showflat&Number=3052074#Post3052074