Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#1653822 - 01/04/09 11:14 AM Problems with Grand Marquis
ARA84 Offline
Stranger

Registered: 12/18/08
Posts: 2
Hi all,

I recently purchased my 1st panther platform car, a 95 grand marquis. It was running perfect till last week when it juz refused to start. If i wanted to use the car i had to jump start it. The thing is i juz purchased a new battery for the car. The battery's barely a month old. Could it be an alternator? And whenever i am waiting at a light, the engine would suddenly die. But would start up immediately after that wif no problems. This happens whenever the car is idle for awhile. Sorry about the stupid questions but i'm new wif these cars and am still learning about them. Thanx.

Top
Links
#1653933 - 01/04/09 02:18 PM Re: Problems with Grand Marquis [Re: ARA84]
gord_bolton Offline
Over the Hill

Registered: 05/06/02
Posts: 4691
Loc: Saskatoon, Saskatchewan
IAC (idle air control valve) problems can cause the car to stall at idle when it is running fine otherwise.

Tell us more about the no start condition. From what you have said I would suspect that your battery connections are dirty or loose.

You need to check the battery voltage when you park it and again before you try to start it. This will tell you if the alternator is charging your battery while you are driving and if something is draining your battery while it is sitting.

I have had the daytime running light module fail so that it leaves the lights on while the switch and ignition is off.

Does the battery spin the starter but the engine fail to fire or is the battery not able to spin the starter.

You may want to check the cables for rot and the connections for corrosion.

Top
#1654204 - 01/04/09 07:58 PM Re: Problems with Grand Marquis [Re: gord_bolton]
ARA84 Offline
Stranger

Registered: 12/18/08
Posts: 2
The battery will not spin the starter. No chime from doors opening and no lights on dash.

Top
#1654224 - 01/04/09 08:44 PM Re: Problems with Grand Marquis [Re: ARA84]
merk44z Offline
n00b

Registered: 12/08/06
Posts: 20
Loc: long island,ny
I've had this problem with 2 of my panthers. Initially, I thought it was the alternator; turned out to be bad starters.
_________________________
Currently own 2 panthers;
2002 Crown Vic LX Sport(black- of course)
1993 Grand Marquis LS (silver) with 210k; looks good, runs strong. Highway package....

GONE BUT NOT FORGOTTEN.....
1992 Town Car with 170k; (sold)
1993 Grand Marquis GS(silver) with 323k; still running strong.(sold)

1989 GM LS with leather
1982 LTD
1997 GM HPP -damn i miss that car...:(

Top

Who's Online
6 registered (Rainbowpizza, bluejay_32, Rootintootin, ismann, Davidzq, 1 invisible), 74 Guests and 286 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 161
a_d_a_m 106
Old_Guy_Stu 102
DudeAbides 54
Moby_Vic 51
CrystalPistol 48
TheCableGuy 43
RF_Overlord 43
Ponyguy 41
Rainbowpizza 36
Member Spotlight
Member Since: 12/14/02
Posts: 1734





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!