Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#1985202 - 02/22/10 12:35 AM Pinging... EGR related?
LTDScott Offline
Climber

Registered: 03/02/01
Posts: 958
Loc: San Diego, CA
Hey all, used to post here years ago but haven't been here in a while. Bought a '97 CVPI back in 2000 and ended up giving it to my dad to drive. Now I've got it back and I'm fixing it up in preparation to sell it.

As long as we've had the car, it has pinged under hard acceleration or under heavy load (going up a long grade in warmer temps). In the last 8 years I have changed plugs, Seafoamed the engine, put in a 180 degree t-stat, and a few months ago I had to replace the intake due to the infamous coolant leak. Nothing has fixed the problem.

I haven't had any EGR related trouble codes, and the car has passed smog every time, so I assumed it was all working fine. But today, for the hell of it, I decided to hook my vacuum pump up directly to the EGR valve while the car was idling. The idle dropped a bit for just a second, but kept running just fine. I thought the car was supposed to stall if the EGR was working correctly. Am I wrong?

From what I've read, the '96+ cars don't have the problems with clogged EGR passages like the earlier cars, but is there anything that I can clean to try before buying parts? Any suggestions on what could be the problem? Thanks!
_________________________
97 P71: ex-Santa Clara County Sheriff
85 'SVT LTD' LX: 93 Cobra motor, 5-speed, Cobra brakes/suspension
02 Focus SVT

Top
Links
#1985374 - 02/22/10 10:40 AM Re: Pinging... EGR related? [Re: LTDScott]
Eaglegcil Offline
Rookie

Registered: 04/05/09
Posts: 79
Loc: Illinois
ok, i'v had the same issue, i changed the timing set on the car and solved it on mine. how many miles are on yours? if it's over 100k, it is probly getting close to needing the chain, for longevity of the engine. this is not 100% the reason for yours, but it was on mine
_________________________
1998 Mercury Grand Marquis LS
--2004 Tail Lights
--Blacked Out Tail Panel
--Head light relay addon setup
--Future J-Mod
--HPP Rims (Looks Great!)
--Few scratch repairs to come...

Top
#1985430 - 02/22/10 11:58 AM Re: Pinging... EGR related? [Re: Eaglegcil]
LTDScott Offline
Climber

Registered: 03/02/01
Posts: 958
Loc: San Diego, CA
Timing set = timing chain and gears? I would assume so since the timing isn't adjustable on this car. The car has 138K miles. If so, that ain't going to happen. I'm not going to invest that much time/money into a $2000 car that I'm about to sell.

I'm still wondering about the EGR though. The fact that the engine didn't stall when the EGR valve had vacuum applied concerns me.
_________________________
97 P71: ex-Santa Clara County Sheriff
85 'SVT LTD' LX: 93 Cobra motor, 5-speed, Cobra brakes/suspension
02 Focus SVT

Top
#1986073 - 02/23/10 09:58 AM Re: Pinging... EGR related? [Re: LTDScott]
LTDScott Offline
Climber

Registered: 03/02/01
Posts: 958
Loc: San Diego, CA
ttt nobody else?
_________________________
97 P71: ex-Santa Clara County Sheriff
85 'SVT LTD' LX: 93 Cobra motor, 5-speed, Cobra brakes/suspension
02 Focus SVT

Top
#1986196 - 02/23/10 01:19 PM Re: Pinging... EGR related? [Re: LTDScott]
Codyy Offline
Fearless Leader
Poobah

Registered: 03/01/09
Posts: 5747
Loc: Up North Eh
I'm not sure about the EGR valve but I can offer some assistance with other pinging causes, since I am suffering from the same issue in my 2004.

Clean the MAF and reset the computer - even replace it if you want too. Could also possibly be the TPS (I am going to replace mine as I think that's what my issue is). Make sure the plugs are gapped correctly, coolant is in good condition and all fans come on when they are supposed to with no obstructions to them or the radiator. Could try changing O2 sensors as well.

You really don't need a 180* tstat unless you have a tune requiring it.
_________________________


Top
#1988113 - 02/25/10 06:48 PM Re: Pinging... EGR related? [Re: Codyy]
enslow Offline
Over the Hill

Registered: 04/06/02
Posts: 1567
Loc: Vancouver
Seafoam treatment. It works best if dumped straight through the throttle body until the engine stalls. Wait about 1/2 day, then drive off. Do this at night because you might produce a LOT of smoke!
_________________________
Testing the multifunction switch (does NOT apply to 2003+)
Testing the MAF
Digital Cluster Repair
Stalag's Coolant Write-up


Enslow ...graemlin waving canadian flag...
'92 Grand Marquis, M75 (sold 2019 after 22 years)

Top
#1988324 - 02/25/10 10:39 PM Re: Pinging... EGR related? [Re: enslow]
LTDScott Offline
Climber

Registered: 03/02/01
Posts: 958
Loc: San Diego, CA
I already did a Seafoam treatment, but just sucked it into a vacuum hose.

How would you dump it into the throttle body without revving the hell out of the engine?
_________________________
97 P71: ex-Santa Clara County Sheriff
85 'SVT LTD' LX: 93 Cobra motor, 5-speed, Cobra brakes/suspension
02 Focus SVT

Top
#1988364 - 02/25/10 11:23 PM Re: Pinging... EGR related? [Re: LTDScott]
Codyy Offline
Fearless Leader
Poobah

Registered: 03/01/09
Posts: 5747
Loc: Up North Eh
I've only ever done Seafoam through the brake booster vacuum line.

How much did you run through it LTDScott? Did it help at all?

You can put some through the gas and oil as well (although oil wouldn't help much for pinging probably, you could still use it for maintenance).
_________________________


Top
#1988532 - 02/26/10 09:28 AM Re: Pinging... EGR related? [Re: Codyy]
LTDScott Offline
Climber

Registered: 03/02/01
Posts: 958
Loc: San Diego, CA
Yeah I'm pretty sure I used the brake booster line too. I did this several years ago and ran half a can through there. I was surprised to see hardly any smoke out of the tailpipe when I did this. Maybe I ought to try again.
_________________________
97 P71: ex-Santa Clara County Sheriff
85 'SVT LTD' LX: 93 Cobra motor, 5-speed, Cobra brakes/suspension
02 Focus SVT

Top
#1988599 - 02/26/10 11:30 AM Re: Pinging... EGR related? [Re: LTDScott]
stalag Offline
Over the Hill

Registered: 03/29/09
Posts: 3983
Loc: Columbus, OH
97 model year Grand Marquis and other panther platform vehicles has a problem with the MAF/programming. There is a TSB on this issue and the fix is to replace the MAF and have a Ford Dealer reprogram the car. I actually had to do this repair. The new code upgrade should be around $70 bucks and the MAF is more like around ~$150. It is so easy to replace the MAF I would do it yourself but to get the other half of the fix you will need to cite the TSB in question.

97-21-6 OCT 97 Engine - Detonation/Spark Knock On Acceleration

Hope this helps.

Stalag

P.S. Pulled off this website http://www.policecars.us/crvicrectsbs_home.html


Edited by stalag (02/26/10 01:09 PM)
_________________________
Stalag;___________Just for Rizzo I am posting this in my sig. Coolants
2001 Lincoln Town Car Cartier L, 1997 Mercury Grand Marquis (extinct)
On my LTC the following mods/upgrades were added. Heinous motorsport control arms, Command Automotive SD-1 rotors (these rotors can no longer be obtained), Calipers by Goldlinebrakes.com in silver with Hawk HPS pads (now running Ford OEM), MSD COP's. MZT is also applied with programming from BOC. j-mod is now done. Final rebuild of transmission done by Gearstar.

Top
#1988610 - 02/26/10 11:42 AM Re: Pinging... EGR related? [Re: LTDScott]
Big_Bad_Joe Offline

Poobah

Registered: 12/12/01
Posts: 8468
Loc: Rochester NY
wow some bad tech around this board lately

No that little test doesnt mean the car always stalls.

nOw as to actual problem it could be the infamous DPFE sensor... that controls the EGR and can lead to pinging and other issues....

the other common thing most people miss is that the 97 still had an engine driven fan. Since you dont get any codes and it has done this for 8 years it very well could be that your fan never does engage enough... check that out also

if your egr was actually that faulty you would get a code or fail the stringent CA smog tests I would think

just some thoughts
_________________________
2006 LX with HPPBlue, Light Camel Interior,Magnaflow Exhaust,PI Zip Tube
Underdrives from ADTR.net
Pioneer AVIC X930BT Nav system, JL xD400/4amp, JL Speakers, Audiovox backup camera
Given to DG in Ohio

2013 Ford Expedition Limited EL, Pearl White

2000 HPP RESURECTION RIP 8/17/2012 died in Dayton OH

Top

Who's Online
6 registered (Rainbowpizza, bluejay_32, Rootintootin, ismann, Davidzq, 1 invisible), 74 Guests and 286 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 163
a_d_a_m 106
Old_Guy_Stu 102
DudeAbides 54
Moby_Vic 51
CrystalPistol 48
TheCableGuy 43
RF_Overlord 43
Ponyguy 41
Rainbowpizza 38
Member Spotlight
Member Since: 12/14/02
Posts: 1734





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!