Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#2902642 - 06/16/15 08:23 PM Horn Not Working
Interceptordude Offline
Stranger

Registered: 06/14/15
Posts: 4
Loc: Earth
2010 Police interceptor horns are still plugged in on car wires are not cut but when you go to blow the horn its just dead the fuse looked good so just wondering if anyone else had any suggestions thanks.

Top
Links
#2902747 - 06/17/15 12:47 PM Re: Horn Not Working [Re: Interceptordude]
jgorm1 Offline
Member

Registered: 02/08/11
Posts: 317
Loc: san diego
check the relay. Swap it with a fuel pump, headlight, etc and see if that fixes it.
_________________________
03 LX sport
02 Kenne bell mustang
03 E450 7.3 PSD motorhome 4" exhaust
06 rubicon on 35s
All custom tuned by me.

Top
#2902763 - 06/17/15 02:52 PM Re: Horn Not Working [Re: jgorm1]
Interceptordude Offline
Stranger

Registered: 06/14/15
Posts: 4
Loc: Earth
ill try it when I get a free moment thanks ill let you know if it fixes it.

Top

Who's Online
2 registered (bluejay_32, Rainbowpizza), 64 Guests and 264 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 164
a_d_a_m 105
Old_Guy_Stu 102
DudeAbides 54
Moby_Vic 51
CrystalPistol 48
TheCableGuy 43
RF_Overlord 43
Ponyguy 41
Rainbowpizza 38
Member Spotlight
Member Since: 12/14/02
Posts: 1734





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!