Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Page 2 of 2 < 1 2
Topic Options
#4063134 - 05/14/20 09:34 AM Re: 93 crown vic help needed [Re: 420chunk]
88grandmarq Offline

4R70W rebuilder
Poobah

Registered: 07/10/02
Posts: 6797
Loc: Indiana
Originally Posted By 420chunk
I did the shifter tube replacement Sat. Took a few hrs. Amazing difference. You don't know how bad it is till you fix it. Should have done just bushings. Be sure to check/tighten fasteners on front linkage .mine weren't tight as spec. Front end of shifter tube


how is this related the original posters problem?
_________________________
2011 P7B - retired Jay county Indiana Sheriffs car
2003 Lincoln Town Car Signature - 3.27 RAR, dual exhaust and J-mod - SOLD 09/2011
89 Crown Victoria LX- HPP Box - SOLD 09/2010
88 Grand Marquis LS - The original - Totaled 5/2006

I rebuild AODE/4R70W/4R75E Transmissions, check out my Facebook page for my latest project; https://www.facebook.com/Ford-transmission-repairs-Jmod-348414635312478/

Top
Links
#4063218 - 05/14/20 08:00 PM Re: 93 crown vic help needed [Re: BlackBettyDaVic]
420chunk Offline
Stranger

Registered: 08/16/19
Posts: 5
Loc: North texas
I Must have got lost on the site. Answered wrong post. I was so happy her car got fixed and she can drive it now.


Edited by 420chunk (05/14/20 08:09 PM)

Top
#4064134 - 05/21/20 09:11 PM Re: 93 crown vic help needed [Re: BlackBettyDaVic]
BlackBettyDaVic Online   content
n00b

Registered: 04/16/19
Posts: 10
Loc: Ohio
So for an update I no longer have a check engine light but my car is still having an issue still while I'm driving it seems like it is maybe going into overdrive or something like that maybe torque converter lockup problems 30 miles an hour on up I have replaced the lock-up solenoid the shift solenoid the filter and almost all the fluid even drained the torque converter I've also replaced my throttle position sensor the next thing I was going to try with the vehicle speed sensor because I really feel like it's going into lock up because if I hit the brake lightly it'll accelerate properly again for a couple seconds same when I let off the gas and press it again

Top
#4064140 - 05/21/20 09:12 PM Re: 93 crown vic help needed [Re: BlackBettyDaVic]
BlackBettyDaVic Online   content
n00b

Registered: 04/16/19
Posts: 10
Loc: Ohio
Also I might add the car is running beautifully now besides this stupid issue I'm having like if I floor it will go through all four gears perfectly and fast but it's when I'm not flooring it that I have the issue

Top
Page 2 of 2 < 1 2

Who's Online
8 registered (Gilly, dsanchez, DoublePrime, Old_Guy_Stu, OSB, 1 invisible), 125 Guests and 104 Spiders online.
Key: Admin, Global Mod, Mod
Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
bluejay_32 252
Blu 111
av8or1 89
Old_Guy_Stu 86
Moby_Vic 79
a_d_a_m 77
2004_p71 75
BigMerc96 72
BigJon 69
DudeAbides 61
Member Spotlight
Member Since: 12/14/02
Posts: 7034





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!