Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4067878 - 06/18/20 02:16 PM 2011 Crown Victoria P7B Transmission issue??
TexCVPI Offline
Stranger

Registered: 06/17/20
Posts: 5
Loc: Texas
I just took delivery of a 2011 P7B with 126K on it. Its having several issues. when I put it in D it seems like the 1-2 shift is super hard at partial throttle. then quick shifts to 3 rd. If I try and take of in second at partial throttle. the car seems to surge. At least that is how it feels. If I drive the car full throttle it'll shift and act normally. If i manually use the 1,2, then to D it shifts fine. Secondly the car will die if you shift quickly from R to D. only after it warms up. NO CEL or Wrench on. No trans error codes when hooked up to my scanner. I can drive around with live data and trans data shows normal. Trans fluid has no metal in it. looks aged but not terrible.


Edited by TexCVPI (06/18/20 02:18 PM)

Top
Links
#4067890 - 06/18/20 03:54 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
TheCableGuy Offline
Climber

Registered: 04/08/19
Posts: 780
Loc: Far Northwest AZ
Drop the pan man lol. I would also be inclined to drop the valve body to look at 1-2 spring in the bore. That’s my wild guess. Maybe a pressure leak? Also, just wondering, how’s overdrive?
_________________________
2010 P7B 149K. 11K hours. 3.27, RKE, Cruise, Ported stock plenum, JMod
2011 Sierra 1500 155K, too many mods to list. (RIP 01-05-2019)
2001 Durango R/T 5.9. 230K. SOLD 5-1-19

I’m a classical textbook over-thinker.


Top
#4067894 - 06/18/20 04:11 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
TexCVPI Offline
Stranger

Registered: 06/17/20
Posts: 5
Loc: Texas
Overdrive works just fine no issues up in 3-4. Overdrive button works as it should. I was suspecting pressure getting past the check balls. I’ll have to get in there and see what I can’t find. I’m just procrastinating hoping someone would tell me something easy. It’s getting toasty down here in south Texas.


Edited by TexCVPI (06/18/20 04:12 PM)

Top
#4067900 - 06/18/20 05:34 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
TheCableGuy Offline
Climber

Registered: 04/08/19
Posts: 780
Loc: Far Northwest AZ
Waiting for 88grandmarq to chime in lol.
_________________________
2010 P7B 149K. 11K hours. 3.27, RKE, Cruise, Ported stock plenum, JMod
2011 Sierra 1500 155K, too many mods to list. (RIP 01-05-2019)
2001 Durango R/T 5.9. 230K. SOLD 5-1-19

I’m a classical textbook over-thinker.


Top
#4067904 - 06/18/20 06:44 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
Lance01 Offline
Member

Registered: 04/02/18
Posts: 326
Loc: Pa
Originally Posted By TexCVPI
Overdrive works just fine no issues up in 3-4. Overdrive button works as it should. I was suspecting pressure getting past the check balls. I’ll have to get in there and see what I can’t find. I’m just procrastinating hoping someone would tell me something easy. It’s getting toasty down here in south Texas.


Sounds like you already know what you need to do...lol

Won't hurt a thing to open up the valve body to inspect and replace worn parts as well as the springs and accumulator pistons. Aside from replacing worn fluid and ensuring the fluid is at the proper level that's about all you can do without going further into the transmission.

Top
#4067906 - 06/18/20 06:59 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
TexCVPI Offline
Stranger

Registered: 06/17/20
Posts: 5
Loc: Texas
Yeah I know what what I need to do. You know how it goes. Anyways. Any good places to get parts?

Top
#4067916 - 06/18/20 07:59 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
Lance01 Offline
Member

Registered: 04/02/18
Posts: 326
Loc: Pa

Top
#4067922 - 06/18/20 08:41 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
TexCVPI Offline
Stranger

Registered: 06/17/20
Posts: 5
Loc: Texas
I see on that site where I can choose 4r75w. When I click on parts they all only show 4r70w are internals compatible?

Top
#4067998 - 06/19/20 03:21 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
Lance01 Offline
Member

Registered: 04/02/18
Posts: 326
Loc: Pa
Aside from the epc solenoid, the valve body components for a 4r70w are the same for the 4r75


Edited by Lance01 (06/19/20 03:22 PM)

Top
#4068006 - 06/19/20 05:08 PM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
TexCVPI Offline
Stranger

Registered: 06/17/20
Posts: 5
Loc: Texas
What trans should i have? 70W, 75W, 75E?

Top
#4068220 - 06/21/20 09:53 AM Re: 2011 Crown Victoria P7B Transmission issue?? [Re: TexCVPI]
Prospect62 Offline
CVN 10 Year
Member

Registered: 01/15/10
Posts: 220
Loc: Central New York
4R75E
_________________________
2008 CVPI Ex-Nevada Highway Patrol Unit 08-271

Top

Who's Online
0 registered (), 50 Guests and 209 Spiders online.
Key: Admin, Global Mod, Mod
Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
bluejay_32 193
BigMerc96 79
ClayBelt 77
Old_Guy_Stu 66
a_d_a_m 65
Ponyguy 64
Moby_Vic 62
TheCableGuy 57
Psxmoe 46
RF_Overlord 33
Member Spotlight
Member Since: 10/23/03
Posts: 6686





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!