Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4067958 - 06/19/20 08:55 AM Engine Issues...
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
Hey everyone.

I recently scored a 1996 Crown Vic base model (single exhaust, no traction control, just ABS) for $500 from my bosses mother, and everyone who has seen it is surprised how rust free it is, yay!

Anyway, I have had issues with it from the start and now I am unsure what to do.

When I bought it, it overheated. I fixed this by replacing the cracked Ford intake manifold with a Dorman, as it was leaking coolant.

I've replaced the fuel injector caps and o-rings, air intake filter, MAF, air sensor inside the airbox (forgot the name of that, intake air temperature sensor?), engine and transmission oils, replaced idle air control valve, replaced fuel filter, replaced all spark plugs, and cleaned the throttle body.

Now the problem I have is that the car doesn't like to run with small amounts of throttle. I have noticed this is much worse in the summer than the winter. What happens is the car cold starts just fine, but after it warms up, it will stumble and sometimes stall if you feed it a tiny amount of throttle. More throttle is fine. I have stalled driving around 25MPH and lower, or when trying to pull away from a stop more than once, as well as stalling when transferring from Park to Drive or Reverse.

I have noticed the rubber pipe for the air intake to the throttle body has a crack on the back where one of the two lines connect to it (maybe vacuum lines?). I am unsure if this is causing my issue, but the part doesn't have a part number on it, and Ford's website doesn't list the part at all... or any other useful parts which is SUPER annoying. Anyone know the part number for this pipe?

Anytime I try to find parts for my 1996, I only find stuff for 1998+ which obviously doesn't work for my car.

As a side note, my fuel pump whines constantly. I can hear it just sitting in the drivers seat. Is it possible that is the problem where it can't supply the correct amount of fuel during tiny amounts of throttle?

Any advice would be appreciated. I recently ordered a smoke machine to test for vacuum leaks but I haven't gotten my air compressor functional yet to test with it.

If it helps anyone, my VIN is 2FALP73W3TX198618.

Top
Links
#4067960 - 06/19/20 09:20 AM Re: Engine Issues... [Re: Inali]
Bangster Offline

Poobah

Registered: 11/30/01
Posts: 9173
Loc: Tucson Az
Hmm, I thought it was the earlier ones with the emission tee that split, it isn't this one is it? I guess you are talking about the air intake tube where the IAC and the crankcase vent attach? I picture might help. An unmetered air leak would cause issues, yes.
_________________________
00 Grand Marquis LS Premium - 97 Cougar 4.6 Sport - 89 Cougar LS - 63 Falcon 302 - 82 F-150 - 97 Mark VIII LSC - 2017 Escape SE - 2012 Fusion Sport AWD

Top
#4068016 - 06/19/20 06:09 PM Re: Engine Issues... [Re: Bangster]
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
Originally Posted By Bangster
Hmm, I thought it was the earlier ones with the emission tee that split, it isn't this one is it? I guess you are talking about the air intake tube where the IAC and the crankcase vent attach? I picture might help. An unmetered air leak would cause issues, yes.


Here are some pictures. Also I noticed there's a slotted gap under my MAF, is that normal?

Here's the link to the picture album: https://photos.app.goo.gl/3Uhd7THSZtAPxks68


Attachments
Screenshot_20200619-180452.png

Screenshot_20200619-180502.png

Screenshot_20200619-180511.png




Edited by Inali (06/19/20 06:12 PM)
Edit Reason: Broken picture uploads

Top
#4068112 - 06/20/20 11:08 AM Re: Engine Issues... [Re: Inali]
RF_Overlord Offline

Poobah

Registered: 12/14/02
Posts: 7227
Loc: MA
You can't attach pix here. Vertical Scope broke that feature a couple of years ago and won't fix it. You need imgur or similar...
_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
#4068120 - 06/20/20 12:50 PM Re: Engine Issues... [Re: Inali]
GoldPanther Offline
BOK contributor
Over the Hill

Registered: 07/16/13
Posts: 2836
Loc: Chitcagoland!
In my experience, I had issues with a coil pack, it would work ok when cold but one it's hot it will start, like, sending weak sparks making misfires.
Just a thought.
_________________________
03 mgm ultimate edition.
June 2015 Panther of the Month
December 2018 Panther of the Month
Originally Posted By Black_Chrome
Black_Chrome: If only I had a merc...Oh wait, its still sitting out at the farm frown "This holiday season give that special woman in your life something she deserves. Dans External Relay Harness."


Top
#4068144 - 06/20/20 05:05 PM Re: Engine Issues... [Re: RF_Overlord]
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
Originally Posted By RF_Overlord
You can't attach pix here. Vertical Scope broke that feature a couple of years ago and won't fix it. You need imgur or similar...


Ah, well here they are then:
https://imgur.com/1bQu6j5
https://imgur.com/KUNcqSu
https://imgur.com/osoIyV6

Top
#4068146 - 06/20/20 05:07 PM Re: Engine Issues... [Re: Inali]
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
I read that after someone else swapped intake manifolds, they accidentally got coolant in the cylinders.

Is there an easy way for me to know this, or do I have to find someone to pull the intake manifold and such off to look inside?

Top
#4068172 - 06/20/20 08:50 PM Re: Engine Issues... [Re: Inali]
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
I found out today that my check engine light doesn't illuminate, But I bought a Bluetooth to OBD2 scanner and it says my MIL light should be on, and is throwing a code of p0102.

Top
#4069000 - 06/28/20 01:09 PM Re: Engine Issues... [Re: Inali]
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
So I tried to do a smoke test via the intake pipe and also the evap port, but I didn't see any smoke going anywhere else or leaking anywhere. Is there a better place to do this? Also, my car will now accelerate by itself and runs worse thing before in park.

Top
#4069004 - 06/28/20 02:57 PM Re: Engine Issues... [Re: Inali]
Inali Offline
Stranger

Registered: 01/28/20
Posts: 8
Loc: VT
I noticed there is an obviously missing cap or hose as show red here. Anyone know what it is? I don't see any unplugged and loose hoses anywhere in the engine bay.

https://puu.sh/G1voF/dc59bf3a6f.jpg


Edited by Inali (06/28/20 03:07 PM)
Edit Reason: Fixed image.

Top
#4069012 - 06/28/20 03:39 PM Re: Engine Issues... [Re: Inali]
bluejay_32 Online   content
Poobah

Registered: 08/28/16
Posts: 8021
Loc: wny
Originally Posted By Inali
I noticed there is an obviously missing cap or hose as show red here. Anyone know what it is? I don't see any unplugged and loose hoses anywhere in the engine bay.

https://puu.sh/G1voF/dc59bf3a6f.jpg

What is missing there is the cap for the low side A/C port.
_________________________
2008 Grand Marquis - bought 7/29/16 - 60,210 mi
Inaugural CVNw POTM - December 2018 slug
CVN POTM - February 2019 joy





Originally Posted By IPreferDIY
Sounds like time-wasting gossip to me.

Top

Who's Online
3 registered (GrumpMarky, bluejay_32, 1 invisible), 88 Guests and 179 Spiders online.
Key: Admin, Global Mod, Mod
Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
bluejay_32 245
av8or1 85
Old_Guy_Stu 79
DudeAbides 73
a_d_a_m 73
Ponyguy 47
ClayBelt 43
RF_Overlord 36
Moby_Vic 36
Davidzq 30
Member Spotlight
Member Since: 08/16/11
Posts: 939





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!