Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4071338 - 07/20/20 10:45 PM Weird Idle, misfire., acts weird under load
tucker117 Offline
Stranger

Registered: 07/10/20
Posts: 7
Loc: Ohio
Hello Everyone, My car is running like crap.

Backstory:
So my grand marquis a while back started acting a bit weird not idling right, misfiring, very gutless. I parked her for a semester and drove my dads pt cruiser. Well since the piston went through the side of that car I am fixing up the old couch on wheels.

The engine is from my dads crown vic he bought new in 2000, the frame broke on that vic so we bought back a few years ago a 2001 grand marquis that was clean and ploped the engine in.
The engine at that time was bone stock other than aluminum crossover intake, coils, plugs, oils, filters, and basic maintenance stuff.

Stuff I have done to try to fix her:
These last few weeks I fired her up and she was misfiring on #5 and was super loud. ( turns out someone stole off the cats). I sprayed ether and found that the intake was sucking behind #5. I then checked the maf and seeing that the inside was corroded I replaced it with a hitachi maf. I then replaced the intake with the ford racing one and did the rtv gasket hack. I also have replaced the plugs with motorcraft plugs, reman ebay coils, new vac hoses and pcv thing, new egr valve and gasket, new fuel filter and I had the injectors tested by my friend at the speedshop. New cats from rock auto, denso oxygen sensors all around, new muffler. The car when you first start her up runs mint, then about 9 seconds in she starts misfiring. I have a misfire that every time i clear the code it jumps to a different cylinder. Under load and wide open its a mixed gamble sometimes she bogs down and doesn't want to go other times she runs like a bat out of hell. I checked the fuel trims and they are both around 24%. I have gone back through my work and Everything is tight on the exhuast and intake with no leaks I have found. She idles quite high as well around 900 rpm.

Just a recap. car misfires runs like crap, idles like crap
New: coils, plugs, maf, egr, intake, exhaust system, o2 sensors, fluids/ filters change, injectors checked, tps, pvc vlve, new hoses.

I think my Idle Air valve is shot, its the only thing i can think of other than a shot valve that would cause me to have a lean condition and a misfire that jumps around without reason.

Thank you in advance for any and all input.
-matt
_________________________
2000 2v 4.6 340kish miles in a 2001 body.
Had her since new then the frame rusted in two, put the engine in a donor car.

Top
Links
#4071352 - 07/20/20 11:30 PM Re: Weird Idle, misfire., acts weird under load [Re: tucker117]
bluejay_32 Offline
Poobah

Registered: 08/28/16
Posts: 7436
Loc: wny
Has it been doing this since you changed the engine?

If you put a 2000 engine in a 2001 car you put a NPI engine in a PI car. The heads are different and I think that may be causing all your problems.

I'm sure somebody with more knowledge of NPI engines can chime in and let me know if I'm wrong.
_________________________
2008 Grand Marquis - bought 7/29/16 - 60,210 mi
Inaugural CVNw POTM - December 2018 slug
CVN POTM - February 2019 joy





Originally Posted By IPreferDIY
Sounds like time-wasting gossip to me.

Top
#4071414 - 07/21/20 02:10 PM Re: Weird Idle, misfire., acts weird under load [Re: bluejay_32]
tucker117 Offline
Stranger

Registered: 07/10/20
Posts: 7
Loc: Ohio
The engine ran fine for a while with the npi motor in her. when i swaped the motor I moved it all as one unit. Never changed heads or anything its all original. I also switched over the pcm, pats when i did the swap back in 2012. The issue ive been having has been recent. Shes only been sitting for about half a year.
_________________________
2000 2v 4.6 340kish miles in a 2001 body.
Had her since new then the frame rusted in two, put the engine in a donor car.

Top
#4071420 - 07/21/20 04:47 PM Re: Weird Idle, misfire., acts weird under load [Re: tucker117]
RF_Overlord Online   content

Poobah

Registered: 12/14/02
Posts: 7116
Loc: MA
Originally Posted By tucker117
I checked the fuel trims and they are both around 24%. She idles quite high as well around 900 rpm.
I think these 2 symptoms are the key. LTFT should be close to 0 and STFT will vary depending on driving condition but really shouldn't be anywhere near 24%. Coupled with the high idle, it still sounds like a vacuum leak to me.
_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
#4071466 - 07/22/20 02:02 AM Re: Weird Idle, misfire., acts weird under load [Re: tucker117]
TheShadow Offline

Over the Hill

Registered: 05/01/07
Posts: 1571
Loc: SoCal High Desert
Originally Posted By tucker117
reman ebay coils, ... I have a misfire that every time i clear the code it jumps to a different cylinder.

New: coils, ...


Thank you in advance for any and all input.
-matt



Dump the "reman" coils and buy a cheap new set. Never heard of remanufactured coils...about all that can be done is they're cleaned up a little on the exterior, and made somebody some money.

Check all the coil and injector connectors for looseness, cleanliness, and such. If any are loose and want to back off their jacks, ziptie them securely.

I also second the vacuum leak...
_________________________
'95 P71, 5xx,xxx miles, Rebuilt tranny, 2.73. Lives as a cab, and will die as a cab. (Died-FrontEnder)
'96 P71, 640,xxx on original drivetrain. (Now parts car - T-bone & roll)(You should see the roof - A,B & C-pillars chopped on driver side)
New to list: '96 MGM (Nice! @ 35x,xxx), '97 CV P71, '98 CV P71, '00 CV P71, 01 P71 (2 of 'em) '03 CV P71 (Nice so far) (All Ford Zinc Yellow w/Black decals & trim) And the list is growing...........
Taxicab mechanic: I HATE DRIVERS!

Top
#4071710 - 07/23/20 08:50 PM Re: Weird Idle, misfire., acts weird under load [Re: TheShadow]
tucker117 Offline
Stranger

Registered: 07/10/20
Posts: 7
Loc: Ohio
quick update, Today, I ripped off my ebay coils and "borrowed" my dads f150 genuine motorcraft coils off his truck. After i replaced them i still had the missfire. P0307 #7 misfire. I then moved around the coils and the plugs and it stayed with the cylinder.

I think my new intake has a leak on this cylinder. I retorqued my bolts and that didnt do anything. I tried spraying ether around and underneath the manifold but it didnt really change the idle from what I could tell.

I am thinking about spraying flex seal underneath and around the intake runner to see if that seals it up because I really dont want to replace my intake.

Also my new Iac valve brought the idle down to 780ish rpms.

-matt
_________________________
2000 2v 4.6 340kish miles in a 2001 body.
Had her since new then the frame rusted in two, put the engine in a donor car.

Top
#4071774 - 07/24/20 11:08 AM Re: Weird Idle, misfire., acts weird under load [Re: tucker117]
BigMerc96 Offline

I know nothing
Posting Addict

Registered: 06/05/10
Posts: 19766
Loc: I can see Detroit from here!
Is the intake a Dorman? They have a known vacuum leak issue on NPI heads, been there, done that, have the intake I chucked across the yard in my garage.
_________________________
-Steve

2006 Audi A6 ~132k miles, stock.
1998 Mercury Grand Marquis LS HPP ~100k miles, slowly acquiring modifications.
1997 Town Car Cartier ~145k miles, Ported Plenum, Gutted Airbox, Contour E-fan Retrofit, Dual exhaust with Magnaflows, cats deleted, MSD Ignition, KYB Gas-A-Justs, P71 front bar, air ride reinstated, Projector retrofit, Caddy 4-note horn retrofit, Wood rim steering wheel retrofit, holistic weight reduction as the parts fall off..
1996 Mercury Grand Marquis GS 117,485mi. R.I.P. 7/14/12 frown

Top
#4071778 - 07/24/20 01:59 PM Re: Weird Idle, misfire., acts weird under load [Re: BigMerc96]
tucker117 Offline
Stranger

Registered: 07/10/20
Posts: 7
Loc: Ohio
Its a skp intake I purchased from a farmer on Facebook.

I actually just figured out my issue. I had a bad injector. This morning I was testing the injectors with my multi-meter and the #7 injector had no resistance. I replaced it with a junkyard one and she runs so smooth and powerful. Its like a new car! So i guess is test your injectors is the lesson here.
thank you all for your suggestions.
-matt
_________________________
2000 2v 4.6 340kish miles in a 2001 body.
Had her since new then the frame rusted in two, put the engine in a donor car.

Top
#4071780 - 07/24/20 04:55 PM Re: Weird Idle, misfire., acts weird under load [Re: tucker117]
TheCableGuy Online   content
Climber

Registered: 04/08/19
Posts: 783
Loc: Far Northwest AZ
Just to note, or a question, isn’t SKP just another brand for Dorman or something?
_________________________
2010 P7B 149K. 11K hours. 3.27, RKE, Cruise, Ported stock plenum, JMod
2011 Sierra 1500 155K, too many mods to list. (RIP 01-05-2019)
2001 Durango R/T 5.9. 230K. SOLD 5-1-19

I’m a classical textbook over-thinker.


Top
#4071826 - 07/25/20 01:38 AM Re: Weird Idle, misfire., acts weird under load [Re: TheCableGuy]
tucker117 Offline
Stranger

Registered: 07/10/20
Posts: 7
Loc: Ohio
I think so, it has the same pressed in gaskets and chineeseium look to it. Either way I only paid $75 for it from a guy on facebook so Im just going to use it till it breaks.
_________________________
2000 2v 4.6 340kish miles in a 2001 body.
Had her since new then the frame rusted in two, put the engine in a donor car.

Top
#4071846 - 07/25/20 10:10 AM Re: Weird Idle, misfire., acts weird under load [Re: tucker117]
BigMerc96 Offline

I know nothing
Posting Addict

Registered: 06/05/10
Posts: 19766
Loc: I can see Detroit from here!
The SKP intake like so many others is a clone of the original Dorman design, the one Dorman produced until ~2013. It is actually better than their current design, I've used a few of the "old" Dorman intakes without major issue. My '96 and '97 both had one. The "new" Dorman intakes are pure garbage and should be avoided at all cost. If I had to guess, Dorman's patent expired on their original design in 2013, because around the same time that they redesigned (and ruined) theirs, all of these other no-name intakes appeared on the market that appear to be a carbon copy of the old one. I'm sure the same caveats apply, where its an intake that is functional, but there is no QC so you really don't know if its going to fit properly or if its going to leak.
_________________________
-Steve

2006 Audi A6 ~132k miles, stock.
1998 Mercury Grand Marquis LS HPP ~100k miles, slowly acquiring modifications.
1997 Town Car Cartier ~145k miles, Ported Plenum, Gutted Airbox, Contour E-fan Retrofit, Dual exhaust with Magnaflows, cats deleted, MSD Ignition, KYB Gas-A-Justs, P71 front bar, air ride reinstated, Projector retrofit, Caddy 4-note horn retrofit, Wood rim steering wheel retrofit, holistic weight reduction as the parts fall off..
1996 Mercury Grand Marquis GS 117,485mi. R.I.P. 7/14/12 frown

Top

Who's Online
5 registered (vin48, magic, LTC_Dave, 3fords1, 1 invisible), 56 Guests and 263 Spiders online.
Key: Admin, Global Mod, Mod
Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
bluejay_32 192
BigMerc96 78
ClayBelt 75
Old_Guy_Stu 66
Ponyguy 61
TheCableGuy 58
Moby_Vic 57
a_d_a_m 57
Psxmoe 43
RF_Overlord 36
Member Spotlight
Member Since: 09/24/10
Posts: 57





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!