Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4081024 - 10/17/20 03:11 PM OBD 1 code #332 troubles
gRon_Marqy Offline
n00b

Registered: 05/09/20
Posts: 26
Loc: n.e. Ill
Hey y'all
My 94 Merc has had an engine light come on when it warms up. It codes out with the #332 EGR valve not opening.I have the Haynes manual, so I've run through the books diagnostic testing procedure for the EGR system.
I tested the EGR valve with some vacuum, and it seemed to operate correctly. Also, I tested the vacuum solenoid and EGR valve position sensor per the manual, and they were OK. So, probably an error on my part, I replaced them one at a time, ending with the EGR valve. Still have the same code:
#332 EGR valve opening not detected

BTW, I have the OBD 1 diagnostic tool that I plug into the proper port to read the codes, and I clear the codes by unplugging the unit while it's in the midst of beeping the codes as per the Haynes manual.

Does anybody have any wisdom to shed on my issue?
The car runs great, no issues whatsoever. All gauges read fine...........I'm stumped............HELP!


Edited by gRon_Marqy (10/17/20 03:15 PM)
Edit Reason: spelling malfunction

Top
Links
#4081058 - 10/17/20 07:56 PM Re: OBD 1 code #332 troubles [Re: gRon_Marqy]
Bellwestern80 Offline

Tired All The Time
Over the Hill

Registered: 07/01/11
Posts: 3835
Loc: Evans, Georgia
The EGR channels below the throttle body can get plugged up real bad with carbon and block the flow.

http://www.lincolnsonline.com/tech/00015.html

Worth a try if you haven't done so yet.
_________________________

My Cars:
-1987 Mercury Colony Park LS (330K Miles | H.O. 302) - March 2017 POTM Winner & November 2019 POTM Winner
-1997 Grand Marquis LS (222K Miles | nPI 4.6) - The Daily Workhorse & April 2013 POTM Winner

Do not become complacent with VerticalScope "working" in the background.

Top
#4081078 - 10/17/20 10:55 PM Re: OBD 1 code #332 troubles [Re: gRon_Marqy]
gRon_Marqy Offline
n00b

Registered: 05/09/20
Posts: 26
Loc: n.e. Ill
That my friend, is worth gold!
I'd be willing to bet this is my problem, as I'm very finicky when it comes to making sure things operate properly on my vehicles.
Thank you for the link!
I'll post up when I get this done some time this week.

Top
#4081258 - 10/19/20 12:59 AM Re: OBD 1 code #332 troubles [Re: gRon_Marqy]
88grandmarq Offline

4R70W rebuilder
Poobah

Registered: 07/10/02
Posts: 6818
Loc: Indiana
code 332 is for insufficient EGR flow detected. This almost always happens with when the EGR channels get gummed up in the lower intake manifold. its also common for the EGR feed tube to crack, which reduces gas flow.

_________________________
2011 P7B - retired Jay county Indiana Sheriffs car
2003 Lincoln Town Car Signature - 3.27 RAR, dual exhaust and J-mod - SOLD 09/2011
89 Crown Victoria LX- HPP Box - SOLD 09/2010
88 Grand Marquis LS - The original - Totaled 5/2006

I rebuild AODE/4R70W/4R75E Transmissions, check out my Facebook page for my latest project; https://www.facebook.com/Ford-transmission-repairs-Jmod-348414635312478/

Top
#4081402 - 10/20/20 07:29 AM Re: OBD 1 code #332 troubles [Re: gRon_Marqy]
gRon_Marqy Offline
n00b

Registered: 05/09/20
Posts: 26
Loc: n.e. Ill
Funny you should mention that, mine was cracked. I tried to weld it, to no avail. It must be a really soft steel or aluminum mix as it just burned up even at low heat!
So I went to the old steel putty and basically glued it back together! lol!

When I source all of the parts to do the 3.73 track loc swap, I'll probably also take the time to do the EGR/intake cleanse.

Top

Who's Online
4 registered (alumarine, JAM, 80sDave, Bangster), 69 Guests and 262 Spiders online.
Key: Admin, Global Mod, Mod
Email Login
EMail Login Name
Password
 New users, sign up!
Top Posters (30 Days)
bluejay_32 222
a_d_a_m 86
av8or1 83
DudeAbides 67
Old_Guy_Stu 61
ClayBelt 45
RF_Overlord 34
Ponyguy 34
Davidzq 33
Moby_Vic 29
Member Spotlight
Member Since: 12/29/11
Posts: 196





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!