Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Page 9 of 10 < 1 2 7 8 9 10 >
Topic Options
#4091918 - 01/15/21 06:53 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
RF_Overlord Offline

Poobah

Registered: 12/14/02
Posts: 7403
Loc: MA
Unless it's a Flex-Fuel, the plugs should be gapped at .054.
_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
Links
#4091938 - 01/15/21 08:01 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
Car is cammaned with supporting mods hence the colder plugs and gap.
_________________________


Top
#4092018 - 01/16/21 03:12 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
update........

So went at it again this morning. Switched fuel injectors from bank 2 to bank 1 to rule that out. That didnt solve my issue. Then switched coils from bank 2 to bank 1 and that didnt solve my issue either.

So I let the car idle for alittle just looking and paying attention. Its always that bank 2. I start looking at my sct x4 data log and I am seeing something new or just something I have not paid attention to because I honestly dont know much about reading things like that.

So, Car is somewhat acting up and the reading on my SCT x4 fpdc is dropping from 0.22% and dropping as low as 0.05% and then just jumps to 0.75% in one shoot. Then drops back down to 0.05% in one shoot and from there it starts going up .23-.24%.

I am assuming this is not normal. What am I looking for here? Fuel filter or fuel pump?
_________________________


Top
#4092022 - 01/16/21 03:52 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
RF_Overlord Offline

Poobah

Registered: 12/14/02
Posts: 7403
Loc: MA
As to your spark plug gap, I always thought one didn't change it unless you had increased compression or forced induction. Do your MMR heads increase compression?

Also add the FPDM (Fuel Pump Driver Module) to your list of suspects regarding the Fuel Pump Duty Cycle.

_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
#4092242 - 01/18/21 11:27 AM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
Just wanted to say that I have replaced the fuel filter just for the f**k of it. its a cheap part to replace and I was hoping for a miracle but that wasnt it. Fuel filter wasnt even clogged. I'm starting to think that theres either something with the fuel pump which is actually about a year old and its a motorcraft unit or something wrong with that cylinder head.
_________________________


Top
#4092244 - 01/18/21 12:14 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
can a fuel pump cause issue just o one bank?
_________________________


Top
#4092256 - 01/18/21 12:41 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
RF_Overlord Offline

Poobah

Registered: 12/14/02
Posts: 7403
Loc: MA
I don't see how...

Maybe something with the fuel rail on that bank?
_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
#4092556 - 01/21/21 10:49 AM Re: HELP!!!!!!!!! bank 2 lean [Re: RF_Overlord]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
update.........

Its been a few days. Really havent done much.

Originally Posted By RF_Overlord
I don't see how...

Maybe something with the fuel rail on that bank?


When I swapped over the injectors, I checked out the fuel rail and all was all good.

Went to a mustang guy that lives 15 mins from me. Robs Performance shop in nj. Spoke to the guy and explained my situation. He hooked up his snap on machine and did his thing. He believes that theres something wrong with either timing components or possibly cylinder head.

-timing is off. possibly it jumped a tooth.
symptoms of this would be:
*very sluggish and slow starting
*A rough running engine
*stumbling and backfiring

-Something going on in that cylinder head which could had been caused by timming chain jumping a tooth.

On my part, I guess I can check compression and possibly have my mechanic do a leak down test.

This is just getting worst and worst. Assuming compression checks out ok, Should I just skip the leak down test and remove timing cover and valve cover and inspect?
_________________________


Top
#4092616 - 01/21/21 05:25 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
Compression test done on cold engine.

Cyl 5-140psi
Cyl 6-145psi
Cyl 7-140psi
Cyl 8-140psi

So where do i go from here?
_________________________


Top
#4092644 - 01/21/21 07:26 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
RF_Overlord Offline

Poobah

Registered: 12/14/02
Posts: 7403
Loc: MA
Those numbers are fine.
_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
#4092654 - 01/21/21 08:40 PM Re: HELP!!!!!!!!! bank 2 lean [Re: RF_Overlord]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
Originally Posted By RF_Overlord
Those numbers are fine.


Yes they are. So i guess i will go ahead and remove valve covers and timing cover and inspect timing.
_________________________


Top
#4092832 - 01/22/21 08:30 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
Did a wet compression test today and all cylinders were at 150-152 psi.

This tells me that block and pistons are all good. I now need to do a leak down test. If leak down test checks out ok, then this tells me that timing jumped a tooth.
_________________________


Top
#4092992 - 01/23/21 03:27 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
MIHAYLA Offline
Rookie

Registered: 08/05/13
Posts: 55
Loc: UA
However. Dear friend, do not rush to disassemble the motor. I repeat: switch Forskan to oscilloscope mode and show how oxygen sensors work. In normal and abnormal mode. Second - take a real oscilloscope and check the duration of the opening of EACH injector. Then give this data to Marty. Everything in this world has a physical cause.
_________________________
MGM92
LTC05

Top
#4093006 - 01/23/21 06:19 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
ford05 Offline
Poobah

Registered: 07/24/08
Posts: 5913
Loc: New Jersey
Is this useing the PIDS for datalogging?

Marty and jeff have both remotely datalogged my car when car several times in several occations. At cold starts, while idling, while driving and even when car was acting up. Everything checked out ok on there end. At this point they done all they can trouble shooting. They suspect something has gone wrong some where and its not tune related.

Going through all my message with marty i realized that in september my car had overheated do to a my radiator taking a crap. There was coolant everywhere. Luckly i made it home but i had lost a good 2 gallons. After relacing radiator with aluminum radiator which took me 2 weeks due to delivery, this is when i started texting marty with this situation
Something happen after this situation.
_________________________


Top
#4093012 - 01/23/21 06:47 PM Re: HELP!!!!!!!!! bank 2 lean [Re: ford05]
CrystalPistol Offline
Over the Hill

Registered: 10/16/01
Posts: 2840
Loc: Shenandoah Valley
I am guessing it's not loosing coolant, no steam in exhaust, no excess moisture in oil? How did plugs look?
_________________________
Toreador Red 2001 Mercury Grand Marquis W/M
_________________________________

WTH?

facepalm I signed it ...
... and now my name appears in "Fat Sharpie Red " across my screen. shrug



Top
Page 9 of 10 < 1 2 7 8 9 10 >

Who's Online
5 registered (KDNYC, DudeAbides, Old_Guy_Stu, Bangster, 1 invisible), 88 Guests and 204 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 325
CrystalPistol 309
a_d_a_m 222
Rainbowpizza 154
DudeAbides 140
Moby_Vic 97
JeffBoudah 97
Old_Guy_Stu 82
Ponyguy 76
Bangster 58
Member Spotlight
Member Since: 10/28/06
Posts: 588





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!