Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4111810 - 06/06/21 11:00 AM Need some help : 2008 CVPI with ?electrical? Issue
RandomPerson Offline
Stranger

Registered: 06/01/21
Posts: 3
Loc: CT
Hello, I own a 2008 CVPI, that seems to be having weird electrical issues.

Story: have been having issues with the turn signals on the car for the past few weeks, and considering the multiswitches are so cheap, I had replaced it and the fuse for the lights which had blown. On Memorial Day as I was leaving i noticed it was blown again, and me being quick and dumb threw a 20A fuse in there so that I could just drive to work and worry about it later. As i was waiting at a light the car faceplanted, died completely. Shifted it into neutral, tried to crank, and got nothing. Luckly i was on a hill and was able to roll to the side. I feel like me adding 20A fuse was a fault but it could be something compltetly unrelated.We tried jumping it, and she still had nothing.

Sympotoms:
-Key in Pre-Start position, no dings, no radio, no blower motor, no sound of fuel pump running, and no instrument panel, only things that have power are the powered mirrors, the seat, and the cig lighter ( the important things)
-When attempting to start, no click from a starter either
-Car is locked into park, no matter what order or way you operate the handle and wheel and key, it wont shift into neutral .

I have replaced the alternator and battery this week as last ditch hope that it was something simple, but alas im still here with a dead car.

IF there's any details you need please let me know, I'm not going anywhere XD

Thanks in advance, Matt

Top
#4112478 - 06/14/21 09:02 PM Re: Need some help : 2008 CVPI with ?electrical? Issue [Re: RandomPerson]
RandomPerson Offline
Stranger

Registered: 06/01/21
Posts: 3
Loc: CT
UPDATE : So it was a bloody fuse. Fuse 7 (PCM Power relay) in the engine bay, after careful examination was burned through, but it wasn't obvious on first glance. However now the engine wont turn over. Engine cranks, Fuel pump whines, and after spraying some starter spray into the intake, it tried to start making me think it has spark, but it wont turn over. Engine has 10 Codes that were not present before this mess.

P2110: Throttle Actuator Control System Forced Limited RPM (2x)
P2104 Throttle Actuator Control System Forced Idle (2X)
P0223 Throttle/Pedal Position Sensor/Switch B Circuit High (2X)
P0183 Fuel temperature Sensor A circuit High (2X)
P0122 Throttle / Pedal Position Sensor Switch A Circuit Low (2X)

I have a cheap little OBD2 Port reader so I cant get anything more than that I'm afraid. A quick look at all of these show severe issues regarding the sensors themselves, or something else ( IE Throttle body, spark plugs, etc). I will begin digging deeper into it. If anyone has any ideas let me know, coulda fried the PCM, or coulda fried everything :/

EDIT: If this is better off in the Powertrain or some other section of the forums please let me know and I can delete and move it somewhere more appropriate.


Edited by RandomPerson (06/14/21 09:03 PM)

Top
#4112516 - 06/15/21 11:51 AM Re: Need some help : 2008 CVPI with ?electrical? Issue [Re: RandomPerson]
RandomPerson Offline
Stranger

Registered: 06/01/21
Posts: 3
Loc: CT
Update2: Car Runs now, Car seems solved. I took every fuse, relay, and diode out, cleaned them with contact cleaner, and refitted them, and now it works. Cant say which fuse or relay was the problem but this was a simple case of check twice, work once.

Top

Moderator:  88grandmarq, RF_Overlord 
Who's Online
0 registered (), 26 Guests and 283 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 111
Old_Guy_Stu 85
Ponyguy 62
a_d_a_m 58
Moby_Vic 56
Dmblanch 46
DudeAbides 41
JeffBoudah 36
Lance01 35
Davidzq 33
Member Spotlight
Member Since: 09/05/12
Posts: 2763





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!