Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4112050 - 06/09/21 01:49 PM 2007 p71 drives in neutral no reverse.
vodomagoo Offline
Stranger

Registered: 05/24/19
Posts: 1
Loc: SC
I have a Ford rebuild tranny in my 07' with approx 30k miles on it. Recently reverse won't move, the car actually feels like it's lurching forward and it's a hard stop. Neutral drives like it's in drive.

When the car is not running neutral and reverse both allow the car to be pushed or rolled backwards.

I replaced the mlps and confirmed the new one is showing the positions correctly when I am hooked up to the obd port while driving and moving the selector. Also overdrive functions correctly. The lines on the tranny and sensor line up correctly as well.

Any ideas on what this could be? Seems to me like a solenoid issue or wiring harness might be trashed but haven't dropped the pan yet.

Also I will got the wrench dash light when I had the issue the first time but didn't see anything on my PC scanner on an issue that would have caused this.

I'd prefer to not have to get a rebuild lol so I'm crossing my fingers.

Top
Links
#4112054 - 06/09/21 03:23 PM Re: 2007 p71 drives in neutral no reverse. [Re: vodomagoo]
Davidzq Online   happy
Member

Registered: 01/19/15
Posts: 493
Loc: Seattle, WA
Linkage isn't properly adjusted.
_________________________
David Hensley
Member of Northwest Panthers Car Club

2008 P71, Norsea Blue SAP
-Message Center cluster retrofit
-Towncar Signature L heated power seats
-Long overhead console
-Compustar remote start/security

Top
#4112178 - 06/10/21 08:37 PM Re: 2007 p71 drives in neutral no reverse. [Re: vodomagoo]
professorP7B Offline

Member

Registered: 04/02/20
Posts: 313
Loc: Rhode Island
If the pan was ever down I wonder if the manual valve was correctly positioned in the linkage. Otherwise, I agree with DavidZQ, this sounds like a linkage issue.
_________________________
Teacher/Technician. First-time Ford owner. ASE-certified Advanced Level Specialist.
Current vehicles:
2011 Crown Vic P7B (SAP, former campus police vehicle)
Purchased 3/27/20 w/51K, 819 idle hrs.
The garage queen...
2011 GMC Sierra 1500 SLE
Purchased 2/23/17 w/57K
5.3L LC9 V8 4X4 Ext. Cab
The trusty steed...
2009 Buick Lucerne CX, AKA "Moby Dick"
Purchased 3/23/21 w/91k
3.9L High Value V6
The Great White Whale...

Top

Who's Online
5 registered (Davidzq, BlackNFast, WESTCOASTP71, hot__box, 1 invisible), 48 Guests and 254 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 111
Old_Guy_Stu 85
Ponyguy 62
a_d_a_m 58
Moby_Vic 56
Dmblanch 46
DudeAbides 41
JeffBoudah 36
Lance01 35
GM_Guy 32
Member Spotlight
Member Since: 08/14/04
Posts: 22010





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!