Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4123944 - 10/09/21 08:29 PM 2001 high idle
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
I have a 2001 that is giving me a fit with the idle once the engine warms to its peak running temp. It runs great and idles around 800 rpm until it gets completely warmed up. Once it is warm it wants to idle at around 2200 rpm in neutral and park. I replaced the IAC with a new motorcraft one from Ford. Have replaced all the vacuum lines and sprayed carb cleaner all around the intake and throttle body and vacuum lines with no increase in idle. I cleaned the MAF sensor and cleaned the throttle body also. No leaks in the air tube to throttle body. Throttle return spring is tight and returns throttle to closed position. When it goes to high idle (2200 rpm) it stays steady there and does not lower. However if I turn the engine off and immediately restart it it will idle normal again. There is no check engine light or engine codes. Anyone know what the problem could be? Its driving me crazy. If I leave the car in gear it still idles high but not at 2200 rpm.
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top
Links
#4123976 - 10/10/21 09:43 AM Re: 2001 high idle [Re: JSO2003P71]
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
I know, its a tough one. I am wondering if it is a problem with the ecm since turning the car off and restarting it make it run normal for awhile.
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top
#4123988 - 10/10/21 12:50 PM Re: 2001 high idle [Re: JSO2003P71]
Hound Online   drug
Rookie

Registered: 03/30/19
Posts: 99
Loc: Virginia
Did this just start happening out of the blue or did it start after you did some other work?

Could it be the IAC?
_________________________
2004 Town Car Ultimate in Autumn Red. Marauder box and MAF, Marty tune, 3.73 31 splines with Trac Lok.

Top
#4123990 - 10/10/21 01:54 PM Re: 2001 high idle [Re: Hound]
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
It just started doing it one day. The IAC is new. I bought it from the Ford dealership. Thinking back on it I think it did start about the same time I replaced the fuel pump. Could that have something to do with it? It was a aftermarket fuel pump.


Edited by JSO2003P71 (10/10/21 02:01 PM)
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top
#4123992 - 10/10/21 02:50 PM Re: 2001 high idle [Re: JSO2003P71]
ColescottFTW Offline
Spreadneck
Rookie

Registered: 10/18/20
Posts: 50
Loc: Portland
Did you replace the gasket for the IAC?

Just had this issue, and it was the stupid gasket. Visually looked good, but was bad.

Top
#4123996 - 10/10/21 03:37 PM Re: 2001 high idle [Re: JSO2003P71]
Hound Online   drug
Rookie

Registered: 03/30/19
Posts: 99
Loc: Virginia
More likely this has to do with a sensor than a mechanical part. I don't see how a pump could change your idle speed.

Gasket as Colescott suggests may be a good start. Do you still have the old valve? I would swap them and see if there is a difference. Motorcraft is just contracting this electrical stuff out anyway. Certainly try a new gasket or some sealer.
_________________________
2004 Town Car Ultimate in Autumn Red. Marauder box and MAF, Marty tune, 3.73 31 splines with Trac Lok.

Top
#4124014 - 10/10/21 07:14 PM Re: 2001 high idle [Re: JSO2003P71]
TheShadow Offline

Over the Hill

Registered: 05/01/07
Posts: 1796
Loc: SoCal High Desert
There might be an issue with the throttle plate not sealing completely, intermittently.
_________________________
'95 P71, 5xx,xxx miles, Rebuilt tranny, 2.73. Lives as a cab, and will die as a cab. (Died-FrontEnder)
'96 P71, 640,xxx on original drivetrain. (Now parts car - T-bone & roll)(You should see the roof - A,B & C-pillars chopped on driver side)
New to list: '96 MGM (Nice! @ 35x,xxx), '97 CV P71, '98 CV P71, '00 CV P71, 01 P71 (2 of 'em) '03 CV P71 (Nice so far) (All Ford Zinc Yellow w/Black decals & trim) And the list is growing...........
Taxicab mechanic: I HATE DRIVERS!

Top
#4124028 - 10/10/21 10:33 PM Re: 2001 high idle [Re: ColescottFTW]
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
I am not sure if I changed the gasket or not. If it came with a new one I changed it. I will get a new gasket tomorrow from orielly. The problem started almost a year ago and the IAC was the first thing I changed. I took the car for a ride today with my scanner hooked up so I could check fuel pressure once the car started the high idle. Fuel pressure stayed at 39-40 lbs. Just like always as soon as the temp got half way it started idling at 2200. I was driving down the road with my foot off the accelerator doing a steady 45 mph. I wish I knew more about the what the numbers should be on the OBD2 live data. I do still have the old IAC in the trunk
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top
#4124030 - 10/10/21 10:37 PM Re: 2001 high idle [Re: JSO2003P71]
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
Could a bad TPS cause this? Its strange how it only happens when the engine reaches a certain temp. When it happened today once I got home I turn the engine off and restarted it and it stayed at high idle (2200).
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top
#4124034 - 10/10/21 11:46 PM Re: 2001 high idle [Re: JSO2003P71]
YoungP71dude Offline
Member

Registered: 08/16/19
Posts: 215
Loc: Charlotte, NC
As TheShadow suggested, if the throttle plate isn't sealing, check your Throttle Position Sensor. Chances are it could be busted and it's trying to compensate based off the other intake/exhaust sensors. If your shifting is at all erratic or harsh, those are more symptoms of a bad TPS. You can check this more easily with live data from an OBD2 tool (via absolute throttle position) or a good ol' fashioned multimeter.

Should your TPS be bad, it's easier to replace the entire throttle body assembly as those TPS screws are an absolute pain to remove gracefully and properly without a welder or impact screwdriver.


Edited by YoungP71dude (10/10/21 11:47 PM)
_________________________
Easily the youngest Panther owner on the planet.


2004 P71 - 8/12/2019-present - Teenager-owned and maintained Ex-Sheriff Car w/ 89K miles
- 2.5" Catback Dual Exhaust; Posi 3.73 & Manual on the wishlist
- Noico Sound Deadening; Dual Skar VD-10 Subwoofers
- Repainted to Black by Maaco & I
- Plowed by a minivan and still running better than ever.
- Currently in a "Mad Max" state.

Your imagination, DIY skills and wallet are the only limits when it comes to modifying a Panther car.

Top
#4124044 - 10/11/21 04:47 AM Re: 2001 high idle [Re: JSO2003P71]
Hound Online   drug
Rookie

Registered: 03/30/19
Posts: 99
Loc: Virginia
The test on my 2004 is just two little screws. Had no issues with mine when I took it off while switching throttle bodies.
_________________________
2004 Town Car Ultimate in Autumn Red. Marauder box and MAF, Marty tune, 3.73 31 splines with Trac Lok.

Top
#4124350 - 10/14/21 04:00 PM Re: 2001 high idle [Re: JSO2003P71]
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
I got a complete throttle body with TPS sensor and IAC from the junkyard. Cleaned it up to look like its new. Was going to swap it today but got stuck at the doctors all day.
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top
#4124748 - 10/17/21 02:00 PM Re: 2001 high idle [Re: JSO2003P71]
JSO2003P71 Offline
Climber

Registered: 04/11/13
Posts: 760
Loc: Florida
After swapping out a complete throttle body assembly with a used one I got for $27. at the junkyard the car is fixed. It runs fantastic now. Thanks to all those who responded for your help.
_________________________
2003 cvpi,2008 cvpi,1994 honda accord,1976 camaro,1988 c1500,2001 honda accord,1999 honda accord,1994 suzuki rf900r,2012 Dodge charger,2001 mustang gt,2010 impala,2013 impala,2013 Taurus

Top

Who's Online
1 registered (Hound), 29 Guests and 63 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 130
Old_Guy_Stu 105
SocalSam 92
JeffBoudah 66
Dmblanch 63
Moby_Vic 62
a_d_a_m 62
Hound 58
Ponyguy 57
Armada Master 54
Member Spotlight
Member Since: 04/03/09
Posts: 6130





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!