Make payments with PayPal - it's fast, free and secure! registry | CVN on Facebook | tech | news | email login Make payments with PayPal - it's fast, free and secure!


Welcome to CVN - Your Panther platform headquarters!


Custom Search


Topic Options
#4125752 - 10/25/21 05:58 PM 2009 PI wont rev past idle in moving gears
Stangstinger Offline
n00b

Registered: 09/01/15
Posts: 17
Loc: NE, USA
Hello again. So I previously posted here about my vic's transmission being slow to engage and slipping into forward gears. I broke down and had it rebuilt. The rebuilder says it engages instantly into all gears now. However, when putting the vehicle into a moving gear, the car just stays at idle rpms and does not rev. When in park or neutral, the car will rev and you can see it on the tach and hear it obviously, but when in a moving gear, pressing the gas pedal does nothing and the car remains at 800 rpm. It never had any issue like that before, what do you guys think is causing it? Is there any weird police feature, switch, button etc causing it? Thank you all for the help

Top
Links
#4125758 - 10/25/21 06:33 PM Re: 2009 PI wont rev past idle in moving gears [Re: Stangstinger]
TheCableGuy Offline
Over the Hill

Registered: 04/08/19
Posts: 1056
Loc: Far Northwest AZ
Are you sure it’s in the correct gear? Maybe they didn’t put the shift lever thingy(whatever the F it’s called) located in the valve body back in the correct position? What does it do on manual 1 or 2?

Did you take it back to the shop? I would at this point.
_________________________
2010 P7B 150K. 11K hours. 3.27, RKE, Cruise, Ported stock plenum, JMod, ADTR sway bar, KYB rear shocks. DIY Headlight harness upgrade, with projector retrofit: Mini H1’s.

Previous rides:
2011 Sierra 1500 155K, too many mods to list. (RIP 01-05-2019)
2001 Durango R/T 5.9. 230K. SOLD 5-1-19

They laugh at me because I’m different. I laugh at them because they’re all the same- Heath Ledger


Top
#4125762 - 10/25/21 06:46 PM Re: 2009 PI wont rev past idle in moving gears [Re: Stangstinger]
Stangstinger Offline
n00b

Registered: 09/01/15
Posts: 17
Loc: NE, USA
It is at the shop. It acts the same on 1 and 2 as it does in R or D. To be clear, putting it in these gears does engage them, and the car does creep, but pressing the gas does not get more power from the engine and it doesn't rev up. The builder says it seems like it's getting no air or gas or something, or has a clogged cat, but the car had no codes and drove just fine before the rebuild (albeit with the aforementioned slipping and delay into forward gears. Once it finally was in gear, drove normal with no problems). I wonder if it is what you mention with the valve body, ill inquire about that. Thanks for the response!

Top
#4125790 - 10/25/21 10:52 PM Re: 2009 PI wont rev past idle in moving gears [Re: Stangstinger]
fordoldfart Offline
Climber

Registered: 10/27/09
Posts: 776
Loc: kansas
This is a fly by wire car. If the range selector on the transmission isn’t
set right it might not let the engine rev up


Edited by fordoldfart (10/25/21 11:13 PM)

Top
#4125916 - 10/26/21 04:15 PM Re: 2009 PI wont rev past idle in moving gears [Re: Stangstinger]
Stangstinger Offline
n00b

Registered: 09/01/15
Posts: 17
Loc: NE, USA
Thank you guys for the ideas. I presented these, and happy to report back that all is well and things are normal now! Though, despite these suggestions, the builder mentioned something about ABS being an issue while the car was in the air as well, which he said was also part of the problem that it was having before? In any case, happy its fixed and I can finally drive it now smile

Top
#4125928 - 10/26/21 04:55 PM Re: 2009 PI wont rev past idle in moving gears [Re: Stangstinger]
RF_Overlord Offline

Poobah

Registered: 12/14/02
Posts: 7769
Loc: MA
Yeah, ABS will act wonky when the car is in the air. The back wheels will be going around and not the front, so there's a wheel-speed mis-match.

So what did they say the actual problem was?
_________________________
'03 Mercury Marauder (The Blackbird)
Trilogy Motorsports supercharged #61
Too many mods to list / Driveway Queen

'04 Grand Marquis LS Limited Edition (Spruce Green)
Daily Driver (Thanks, Adam!)

'00 Grand Marquis GS (Silver)
Rotted frame and broken transmission crossmember
Being resurrected...slowly.

Top
#4127312 - 11/09/21 04:57 PM Re: 2009 PI wont rev past idle in moving gears [Re: RF_Overlord]
Stangstinger Offline
n00b

Registered: 09/01/15
Posts: 17
Loc: NE, USA
Slow to respond here, but the builder cited to me only that it was a combination of it being fly by wire and an ABS issue with it in the air. I was not able to replicate the issues he was having with it, and when he gave it back to me it drove normal and fine. I feared having to shell out even more money in repairs for a problem he was having with it that I never had, and luckily, it was a fluke of sorts. Appreciate the help from you all!

Top

Who's Online
0 registered (), 51 Guests and 92 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters (30 Days)
bluejay_32 119
SocalSam 87
Ponyguy 62
Dmblanch 53
RF_Overlord 48
Moby_Vic 48
Davidzq 47
DudeAbides 44
Old_Guy_Stu 43
Armada Master 42
Member Spotlight
Member Since: 03/18/06
Posts: 771





Copyright 2000-2015 by Crownvic.net and Steve Spaulding. All Rights Reserved.
The photographs, graphics and data contained in this Web site are the properties of the contributors, or Crownvic.net and may not be used without expressed written consent.
Crownvic.net is not affiliated with the Ford motor company.

Happily consuming the fuel saved by Prius owners!